[deprecated] Using Oracle’s plugins in Firefox

Deprecated post: This post is left here for archival purpose. Beginning in Firefox version 52 released March 7, 2017, installed NPAPI plugins are no longer supported in Firefox.

Enable Oracle’s JRE plugin for Firefox in Linux.

  1. See my other post on Installing Oracle JDK 10.0.1 on Linux.
  2. Create your .mozilla/plugins directory if one isn’t already exists.
    mkdir ~/.mozilla/plugins
  3. Create a symbolic link of the JRE’s libnpjp2.so shared object file in your plugins directory. In my installation, this JRE file is found in /opt/jdk-10.0.1/lib/libnpjp2.so
    ln -s /opt/jdk-10.0.1/lib/libnpjp2.so ~/.mozilla/plugins 
  4. Restart Firefox and browse to one of the JVM tester page to see the version of Java your browser is using.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.